bundle installで「can’t modify frozen String」が出る

スポンサーリンク

Railsアプリをちょっと作ろうと思い、色々Gemfileに書いてbundle installしたところ、以下のエラーになった。

Gem::Ext::BuildError: ERROR: Failed to build gem native extension.

can't modify frozen String

An error occurred while installing rainbow (2.2.2), and Bundler cannot continue.
Make sure that `gem install rainbow -v '2.2.2'` succeeds before bundling.

例によってGoogle先生に聞くと、bundlerのgithubに解決法が書いてあった。

bundle install failed: can't modify frozen String

以下のコマンドを実行後に再度bundle installすれば良いらしい。

gem update --system

あっさり解決して良かった。

コメント

タイトルとURLをコピーしました